Some problems - perhaps user errors. :)

Nov 18, 2008 at 7:52 PM
Hi Rudi,

Big fan of the work you've done on the themes and your blog!

However, I had a few issues with the ExpressionDark and DavesGlossyControls themes - didn't try the others, don't know if they're there.

1) In ListBox (probably other ScrollViewer thingies), the scrollbar is set to Visible instead of Auto, and so always present. Is this desirable?

2) In both themes, it seems like if you don't have an ItemTemplate active in ListBox/ComboBox, and you just use DisplayMemberPath, instead of the selected member you will just get the type name. If I remove the following from the ContentPresenter, it works:

Content="{TemplateBinding Content}" ContentTemplate="{TemplateBinding ContentTemplate}"

However, I am not sure this won't break stuff if I were to use a template.

These are relatively minor issues, but I would love to be able to get past them.

Keep up the good work!

Rune

Coordinator
Nov 19, 2008 at 8:57 AM

Hi Rune,

Tnx for the nice comments... I agree that the scrollbar visibility should be auto & I also fixed the silly porting bug that caused the DisplayMemberPath not too work!

All the fixes are now checked in...

Regards,

Rudi

Nov 19, 2008 at 12:33 PM
In 18090 build, the ComboBox vertical scrollbar now covers the right side of items' text.  How do you adjust the size of dropdown width?  It would be nice to have the dropdown section the same width as the ComboBox.

Coordinator
Nov 20, 2008 at 7:54 AM
The ComboBox's dropdown now has its MinWidth & MaxHeight set!

Keep up the GREAT feedback
Nov 20, 2008 at 3:37 PM
Great.  Looks good.  Now if we can get the TextBlock added.  This is the main control I need for my app to look nice.  I currently set all TextBlocks to Foreground="White", which makes the lighter themes not able to view them.  Is there a workaround for this?  Thanks again.
Nov 22, 2008 at 11:28 PM
Hi Rudi,

Thanks for the update! However, even with the latest version I get some unwanted scrollbars. I made some screenshots for you with XamlPadX that I hope can be useful:

http://silverfox.zoopsia.org/wpf/scrollbar1.png
http://silverfox.zoopsia.org/wpf/scrollbar2.png
http://silverfox.zoopsia.org/wpf/scrollbar3.png
http://silverfox.zoopsia.org/wpf/scrollbar4.png
http://silverfox.zoopsia.org/wpf/scrollbar5.png
http://silverfox.zoopsia.org/wpf/scrollbar6.png
http://silverfox.zoopsia.org/wpf/scrollbar7.png

(The URL manager freaked out on me when adding the links)

The XAML is probably a little clumsy as I just copied some of it from a project, but it shows that with every theme, there is a scrollbar on the right - empty, but present. If the "Auto" setting worked, I don't see why it should show up - but even when I explicitly disable it (as in the screenshots), it remains. If I remove the reference to Theme.xaml, then the "default" WPF theme doesn't show a scrollbar, btw.

Sorry to pester you about this, but I know a lot of people will be using these great themes, so QA is in everyone's best interest. :)

Thanks again,

Rune

Coordinator
Nov 24, 2008 at 8:40 AM
What build number did you us? I just want to reproduce the error on my side?

It might also be that the VSM is not working in XamlPad?
Nov 24, 2008 at 7:15 PM
Hi again,

I reproduced the same in Visual Studio 2008 Sp1 just to make sure it wasn't a XamlPadX problem:

http://silverfox.zoopsia.org/wpf/vsscrollbar.png

The build number is 18259 - i.e. the file I extract from is wpfthemes-18259.zip.

Oh, and since I just noticed you put up 18820, I tried that as well. Deleted the c:\temp\theme.xml file, recompiled the solution, got an error because of the missing file, then extracted from the freshly downloaded archive - hopefully this would avoid any caching issues.

This is a freshly created WPF project, I just put the following in the XAML editor:

<Window x:Class="ThemeTest.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
        
    Title="Window1" Height="246" Width="331">

    <Window.Resources>
        <ResourceDictionary>
            <ResourceDictionary.MergedDictionaries>
                <ResourceDictionary Source="C:\Temp\Theme.xaml"/>
            </ResourceDictionary.MergedDictionaries>
        </ResourceDictionary>
    </Window.Resources>
    
    <Grid>
        <ListBox ScrollViewer.VerticalScrollBarVisibility="Disabled">
            <ListBox.Items>
                <ListBoxItem>Number 1</ListBoxItem>
                <ListBoxItem>Number 2</ListBoxItem>
                <ListBoxItem>Number 3</ListBoxItem>
                <ListBoxItem>Number 4</ListBoxItem>
            </ListBox.Items>
        </ListBox>
    </Grid>
</Window>

This is perhaps not the ideal way to apply the theme, but I guess it should work?

Just let me know if you want me to test anything. I'm eager. :)



Coordinator
Nov 26, 2008 at 12:07 PM
Check build 19051, It should fix your issues...

Thank you for the great feedback... keep it up!
Nov 26, 2008 at 10:15 PM
Hi Rudi,

That fixed it! Thank you very much for using your own time to fix these little issues for me!

Btw, this latest fix also took care of a scrollbar problem I just discovered today, where the size and position of the scrollbar was a little off. No problem now, though!

Excellent work as always, thanks again. :)

Rune